Recent Posts by PromptCare

Gmail+Chrome users on XP/Vista are in for some hard times.

Gmail+Chrome users on XP/Vista are in for some hard times. Google Chrome stopped supporting XP/Vista several months ago.  You could continue to run an older version of Chrome even though not running a current browser would leave you at risk to its security flaws.  (Note: Version 53 is the last supported version for XP/Vista.  You…
Read more

Non-HTTPS Sites Labeled “Not Secure” by Chrome

Non-HTTPS Sites to be Labeled “Not Secure” by Chrome Here's the important part:  this only matters if it's a site where you'd enter any sort of a login or credit card information.  If "Joe's Blog" is not secure, there's no problem there because you're just there to read his pithy observations. Now, if you go…
Read more

Recent Comments by PromptCare

No comments by PromptCare yet.